Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8206877

Remove javac support for 6/1.6 source and target values

    XMLWordPrintable

    Details

    • Type: CSR
    • Status: Closed
    • Priority: P4
    • Resolution: Approved
    • Fix Version/s: 12
    • Component/s: tools
    • Labels:
      None
    • Subcomponent:
    • Compatibility Kind:
      behavioral
    • Compatibility Risk:
      low
    • Compatibility Risk Description:
      Known impact on projects still built under source level 6.
    • Interface Kind:
      add/remove/modify command line option
    • Scope:
      JDK

      Description

      Summary

      Remove support for the 6/1.6 argument to javac's -source, -target, and --release options.

      Problem

      Per the policy described in

      JEP 182: Policy for Retiring javac -source and -target Options http://openjdk.java.net/jeps/182

      support for a particular -source/-target/--release value has a limited lifetime. After discussion on jdk-dev (http://mail.openjdk.java.net/pipermail/jdk-dev/2018-May/001190.html), removing support for 6 was deferred from JDK 11 to JDK 12.

      Solution

      Drop support for 6 and have 7 be reported as obsolete.

      Specification

      No longer accept 6/1.6 as a valid argument and when used report 7/1.7 as obsolete.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              darcy Joe Darcy
              Reporter:
              darcy Joe Darcy
              Reviewed By:
              Jonathan Gibbons
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: