Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8209966

Update minimum boot JDK to 11

    Details

      Description

      This issue proposes to bump the minimum boot JDK to jdk-11+NN once the JDK 11 GA has been released.

      Note that this will *not* change the 'sourceCompatibility' in gradle, which will remain at 10. That can be changed later.

      We already use jdk-11 (EA build 27 or 28) to build and test openjfx 11 and openjfx 12. The Travis and Appveyor builds on the GitHub sandbox still use 10, but there is a GitHub issue in progress to fix this -- https://github.com/javafxports/openjdk-jfx/issues/159

      Making JDK 11 the minimum will allow us to remove obsolete code in javafx.swing that requires qualified exports, and eliminate the need to bundle the Microsoft redistributable DLL files.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kcr Kevin Rushforth
                Reporter:
                kcr Kevin Rushforth
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Due:
                  Created:
                  Updated:
                  Resolved: