Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8210615

Swing interop requires qualified exports when run with JDK 10

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Other
    • Affects Version/s: openjfx11
    • Fix Version/s: None
    • Component/s: javafx

      Description

      The unbundled JavaFX 11 release runs with JDK 10 or later. Prior to JDK 11, the javafx.swing module relied upon qualified exports of internal packages from java.desktop. Now that the javafx.swing module is no longer a part of the JDK, these qualified exports must be specified at runtime.

      These qualified exports are not required when running JavaFX 11 with JDK 11 or later.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kcr Kevin Rushforth
                Reporter:
                kcr Kevin Rushforth
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: