Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8211124

HotSpot vm_version.cpp should recognise updated VS2017

    Details

    • Subcomponent:
    • Resolved In Build:
      b14

      Backports

        Description

        HotSpot needs an update for Windows compiler versions:
        open/src/hotspot/share/runtime/vm_version.cpp
        recognises the Windows compiler VS2017 as _MSC_VER 1912.

        VS 15.6.1 == 1913

        My VS2017 Version 15.6.1 has:

        ** Visual Studio 2017 Developer Command Prompt v15.6.1

        $ cl.exe
        Microsoft (R) C/C++ Optimizing Compiler Version 19.13.26128 for x64
        Copyright (C) Microsoft Corporation. All rights reserved.

        We need to update open/src/hotspot/share/runtime/vm_version.cpp to avoid seeing "unknown MS VC++" in the long VM version string.

        In case I find reference to the link version in the src, thiis comes with link.exe:

        Microsoft (R) Incremental Linker Version 14.13.26128.0

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  kevinw Kevin Walls
                  Reporter:
                  kevinw Kevin Walls
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: