Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8211714

Need to update vm_version.cpp to recognise VS2017 minor versions

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b16

      Backports

        Description

        The hotspot source code doesn't display the correct MSVC++ version when
        compiled by the following versions of VS2017:
        MSVC++ 14.11 _MSC_VER == 1911 (Visual Studio 2017 version 15.3)
        MSVC++ 14.14 _MSC_VER == 1914 (Visual Studio 2017 version 15.7)
        MSVC++ 14.15 _MSC_VER == 1915 (Visual Studio 2017 version 15.8)

        For ex., if the JDK is compiled with VS2017 15.7, it returns "unknown MSVC++: 1914" when run with -Xinternalversion.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mchinnathamb Muthusamy Chinnathambi (Inactive)
                Reporter:
                mchinnathamb Muthusamy Chinnathambi (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: