Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8212003

Deprecating the default keytool -keyalg value

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 12
    • Component/s: security-libs

      Description

      DSA is rarely used anymore and is not supported by newer protocols such as TLS 1.3. We should seriously consider changing the default type to something other than DSA (ex: RSA or EC). Some compatibility issues will need to be considered and documented.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                weijun Weijun Wang
                Reporter:
                mullan Sean Mullan
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: