Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8212014

JavaScriptBridgeTest::testBridgeExplicitOverloading test fails when run with newer JDK 8u

    Details

    • Subcomponent:
      web
    • Resolved In Build:
      master

      Backports

        Description

        The JavaScriptBridgeTest::testBridgeExplicitOverloading test in FX 8u-dev is failing when I run with a recent JDK 8u release such as JDK 8u181.

        $ gradle --info :web:test --tests javafx.scene.web.JavaScriptBridgeTest
        javafx.scene.web.JavaScriptBridgeTest > testBridgeExplicitOverloading FAILED
            java.lang.AssertionError: expected same:<[Ljava.lang.Integer;@7945dc0e> was not:<undefined>
                at org.junit.Assert.fail(Assert.java:91)
                at org.junit.Assert.failNotSame(Assert.java:639)
                at org.junit.Assert.assertSame(Assert.java:578)
                at org.junit.Assert.assertSame(Assert.java:591)
                at javafx.scene.web.JavaScriptBridgeTest.lambda$testBridgeExplicitOverloading$12(JavaScriptBridgeTest.java:582)

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  mbilla Murali Billa
                  Reporter:
                  kcr Kevin Rushforth
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: