Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8214123

Fix Harfbuzz 1.8.2 errors reported by GCC8

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P4
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: client-libs
    • Labels:
    • Subcomponent:
      2d

      Description

      Current harfbuzz 1.8.2 is downstream. I tried 2.1.1, it builds fine standalone but under current Hotspot build umbrella it also produces many errors. So it makes sense to push fixes upstream and then to import fixed version which will probably take longer than the rest of GCC 8 cleanup.

      There are just a few places that require fixing and the are all declarations.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                dchuyko Dmitry Chuyko
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: