Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8217032

Check pandoc capabilities in configure

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 13
    • Fix Version/s: 13
    • Component/s: infrastructure
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b09
    • OS:
      linux

      Description

      The JDK build will try to build manual pages if pandoc is present.

      However that is not sufficient since you also need to check for
      support for the required format.

      JDK uses markdown-smart which isn't present on Ubuntu 16.04 LTS
      which has pandoc 1.16.0.2
      $ pandoc -v
      pandoc 1.16.0.2

      $ pandoc -f markdown-smart
      pandoc: Unknown extension: smart

      It isn't clear to me that there is a way to install an extension
      since the man page for pandoc lists all the supported formats.
      So unless I am missing something this breaks the default build
      on Linux for many folks.
      Note : I have looked to see if this has been reported and I saw discussion but no bug.

        Attachments

          Activity

            People

            • Assignee:
              erikj Erik Joelsson
              Reporter:
              prr Philip Race
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: