Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8217330

Split G1CollectionSetChooser into collection set candidate container and the chooser algorithm

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b08

      Description

      Current G1CollectionSetChooser contains both the collection set candidates (i.e. the set of old gen candidate regions) and the algorithm (and various helper class members) to select these regions from the set of HeapRegions.

      That makes the G1CollectionSetChooser quite a bit hard to read. Ideally something like

      G1CollectionSetCandidates candidates = G1CollectionSetChooser::select_candidates(...);

      would be much easier to read.

      Also remove the really hacky use of GrowableArray.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tschatzl Thomas Schatzl
                Reporter:
                tschatzl Thomas Schatzl
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: