Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8217718

XRender pipeline is not enabled on XVNC4

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: 8, 9, 10, 11, 12, 13
    • Fix Version/s: tbd
    • Component/s: client-libs
    • Labels:
    • Subcomponent:
      2d
    • OS:
      linux

      Description

      XRender pipeline is not enabled on XVNC4. The problem is reproducible on Ubuntu for me. Most likely other Linux platforms and Solaris are affected, as well.

      Steps to reproduce:
      1. Install VNC server and client, (e.g.
      % sudo apt-get install vnc4server
      % sudo apt-get install gvncviewer)

      2. Start up VNC server, (e.g. % vncserver :18 -geometry 800x600 -depth 16)
      3. Start up VNC client, (e.g. % gvncviewer localhost:18)
      4. Run an AWT/Swing application in VNC client with “-Dsun.java2d.xrender=True” option

      Actual result:
      The following message is printed out: “Could not enable XRender pipeline”

      Expected result:
      XRender pipeline should be enabled

        Attachments

          Activity

            People

            • Assignee:
              dmarkov Dmitry Markov
              Reporter:
              dmarkov Dmitry Markov
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: