Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8219403

JVMCIRuntime::adjust_comp_level should be replaced

    Details

    • Subcomponent:
    • Resolved In Build:
      b19

      Description

      JVMCIRuntime::adjust_comp_level calls out to Java, causing various problems for unsuspecting code. We should replace it by taking advantage of the existing compilercontrol compiler directives. A new directive to match modules will most likely be needed.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dlong Dean Long
                Reporter:
                dlong Dean Long
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: