Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8219633

ZGC: Rename ZPageSizeMin to ZGranuleSize

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 13
    • Fix Version/s: 13
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
      gc
    • Resolved In Build:
      b12

      Description

      The size of the unit of memory managed by ZGC is currently called ZPageSizeMin. However, this constant is used in places where we're not necessarily dealing with a ZPage, so calling it ZPageSizeMin isn't quite right. Rename ZPageSizeMin to ZGranuleSize.

        Attachments

          Activity

            People

            • Assignee:
              pliden Per Liden
              Reporter:
              pliden Per Liden
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: