Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8219879

Drop autoconf requirement from 2.69 to 2.63

    XMLWordPrintable

    Details

    • Subcomponent:
    • OS:
      linux

      Description

      On a RHEL 6 or CentOS 6 Linux host one cannot build OpenJDK 8u.

      $ bash common/autoconf/autogen.sh
      Using autoconf at /usr/bin/autoconf [autoconf (GNU Autoconf) 2.63]
      Generating generated-configure.sh
      stdin:33: error: Autoconf version 2.69 or higher is required
      stdin:33: the top level
      autom4te: /usr/bin/m4 failed with exit status: 63

      As it turns out the fix to get autoconf 2.63 support isn't very complex. We should get support for 2.63 since RHEL 6/CentOS 6 is a good build platform for portable OpenJDK builds.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              sgehwolf Severin Gehwolf
              Reporter:
              sgehwolf Severin Gehwolf
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: