Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8220806

invalid --app-version causes failure in windows exe installer

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Duplicate
    • Affects Version/s: internal
    • Fix Version/s: internal
    • Component/s: tools
    • Labels:
      None
    • Environment:

      windows

      Description

      When building an installer on windows, if I use:
      --app-version 13-EA
      then when building the msi installer I get the error message:

      Bundler MSI Installer skipped because of a configuration problem: Version string is not compatible with MSI rules [13.EA].
      Advice to fix: Set the bundler argument "win.msi.productVersion" according to these rules: http://msdn.microsoft.com/en-us/library/aa370859%28v=VS.85%29.aspx

      when using the same think on the EXE instllar type I get

      java.io.IOException: Exec failed with code 2 command [[C:\program files (x86)\Inno Setup 5\iscc.exe,
      with --verbose it will tell me that line 11 of .iss file is invalid.

      The point is, WinMsiBundler checks the version first and gives us a nice message but WinExeBundler does not. Just uses it and gets an error.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                asemenyuk Alexey Semenyuk
                Reporter:
                herrick Andy Herrick
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: