Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8222154

upgrade gtest to 1.8.1

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b22

      Backports

        Description

        gtest v1.7 fork is located in test/fmw/gtest and used for hotspot unit tests. some of currently used native compilers report warnings/errors (e.g. JDK-8197951), so it makes sense to upgrade gtest to the newer released version. as of today, v1.8.1 is the latest released version, so we aim to upgrade to this version unless there are good reasons to use lower version, e.g. big compatibility issues w/ native compilers.

        as we anticipate "small" compatibility issues, we will upgrade the forked/patched version of gtest located in test/fmw. this will also reduce amount of required work and possible divergences.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                iignatyev Igor Ignatyev
                Reporter:
                iignatyev Igor Ignatyev
                Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: