Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8222897

Renaming of shift, rotate operations. Few other api changes.

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: repo-panama
    • Fix Version/s: repo-panama
    • Component/s: hotspot
    • Subcomponent:
    • CPU:
      generic
    • OS:
      generic

      Description

      To make the api easy to use, here are a few changes identified -
      1. Rename shift, rotate operations to be more explicit in what they do. Example, shiftL -> shiftLeft. This also follows the convention used in other libraries; example rotateLeft() in java.lang.Integer.
      2. Added instance methods in Vector.java to create masks and shuffles. The goal is to help programmers by not having to maintain or acquire a reference to Species when creating masks and shuffle. These methods in turn call the static methods in VectorMask and VectorShuffle with the vector's species.
      3. VectorSpecies.boxType() is confusing, rename to vectorType().
      4. Add helper method in Species to determine loop terminating condition.
      5. Cross-lanes operations like addAll() can be renamed to better, descriptive name such as addLanes().

        Attachments

          Activity

            People

            • Assignee:
              kkharbas Kishor Kharbas
              Reporter:
              kkharbas Kishor Kharbas
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: