Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8224214

[AIX] Remove support for legacy xlc compiler

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 13
    • Fix Version/s: 14
    • Component/s: infrastructure
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b13
    • OS:
      aix

      Description

      For OpenJDK 13 we've moved to XLC 16 as required compiler. XLC 16 comes with a new Clang based compiler frontend (called xlclang/xlclang++) which will be used by default but it also still supports the old legacy xlc/xlC compilers.

      As we won't support the old xlc/xlC compilers anyway any more we can remove the extra handling for them from the configure script.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mbaesken Matthias Baesken
              Reporter:
              simonis Volker Simonis
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: