Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8227631

Adjust AIX version check

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 13, 14
    • Fix Version/s: 14
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b06
    • CPU:
      ppc
    • OS:
      aix

      Description

      AIX 5.3 has not been supported since OpenJDK8. Refer to https://wiki.openjdk.java.net/display/Build/Supported+Build+Platforms.

      The currently used xlc 16.1 (XL C/C++ Compilers) also needs AIX 7.1, see http://www-01.ibm.com/support/docview.wss?uid=swg21326972.

      So we should adjust the minimum OS version check done in os_aix.cpp in os::Aix::initialize_os_info().

        Attachments

          Activity

            People

            Assignee:
            mbaesken Matthias Baesken
            Reporter:
            mbaesken Matthias Baesken
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: