Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8227676

Shenandoah: More consistent naming of LRB runtime entry points

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 8-shenandoah, 11-shenandoah, 13, 14
    • Fix Version/s: 14
    • Component/s: hotspot
    • Subcomponent:
      gc
    • Resolved In Build:
      b06
    • CPU:
      generic
    • OS:
      generic

      Description

      Current naming of LRB runtime entry points is a bit weird. We have:

      - load_reference_barrier_JRT (where _JRT doesn't serve any purpose)
      - oop_load_from_native_barrier (which is really like LRB except loading from native memory)

      I propose to rename to:
      - load_reference_barrier
      - load_reference_barrier_native

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rkennke Roman Kennke
                Reporter:
                rkennke Roman Kennke
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: