Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8228503

Rename "rs_lengths" to "rs_length" in ergo code

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b09

      Description

      G1 ergonomics code uses the term "rs_lengths" all over the place to indicate the supposed length of the young gen remembered set.

      Since this is a single value everywhere, rename to "rs_length" as this naming inaccuracy is annoying.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tschatzl Thomas Schatzl
                Reporter:
                tschatzl Thomas Schatzl
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: