Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8229797

[JVMCI] Clean up no longer used JVMCI::dependencies_invalid value

    XMLWordPrintable

    Details

    • Subcomponent:
    • Introduced In Version:
      14
    • Resolved In Build:
      b13
    • CPU:
      generic
    • OS:
      linux

      Description

      The inappropriate use of JVMCI::dependencies_invalid value caused Graal BootstrapWithSystemAssertionsRegisterPressure test crashes with current JDK master (14). We should use dependencies_failed instead of dependencies_invalid and the latter one should be cleaned up.

      For details of this bug, please see https://github.com/oracle/graal/issues/1587

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              pli Pengfei Li
              Reporter:
              pli Pengfei Li
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: