Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8231278

Rename FileMapHeader::_read_only_tables_start to _serialized_data_start

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 14
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b16

      Description

      The name _read_only_tables_start is ambiguous, as there are multiple read-only tables in the CDS archive. It should be renamed to _serialized_data_start, as that where the data is accessed by {ReadClosure,WriteClosure}::serialize.

      See http://hg.openjdk.java.net/jdk/jdk/file/a82fe7a88ce4/src/hotspot/share/memory/metaspaceShared.cpp#l2054

        Attachments

          Activity

            People

            • Assignee:
              iklam Ioi Lam
              Reporter:
              iklam Ioi Lam
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: