Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8231638

G1Analytics::last_known_gc_end_time_sec is poorly named

    Details

    • Type: Enhancement
    • Status: Open
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: 14
    • Fix Version/s: tbd
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
      gc

      Description

      The function G1Analytics::last_known_gc_end_time_sec returns the oldest known GC end time. The word "last" is (much) more suggestive of it being the most recent. It should be renamed to something more suggestive of its actual value, replacing "last" with "oldest" or "earliest" or something like that.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              kbarrett Kim Barrett
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: