Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8232687

No static JNI loader for libprism-sw

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: openjfx14
    • Fix Version/s: openjfx14
    • Component/s: javafx
    • Labels:
      None

      Description

      When the JavaFX native libraries are packaged as static archives and linked into an executable, there is a need for a JNI_OnLoad_foo function for libfoo.a
      We don't have this yet for libprism-sw.a, which does not allow JavaFX to be used in this way on containers/servers with no hardware acceleration support.

        Attachments

          Activity

            People

            • Assignee:
              jvos Johan Vos
              Reporter:
              jvos Johan Vos
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: