Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8232739

Reminder to remove obsoleted flags: -Xconcgc, -Xnoconcgc

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P5
    • Resolution: Duplicate
    • Affects Version/s: 15
    • Fix Version/s: 15
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
      gc

      Description

      remove the following code in arguments.cpp

          // -Xconcgc
          } else if (match_option(option, "-Xconcgc")) {
            warning("-Xconcgc uses UseConcMarkSweepGC; support was removed for both options in 14.0");
          // -Xnoconcgc
          } else if (match_option(option, "-Xnoconcgc")) {
            warning("-Xnoconcgc uses UseConcMarkSweepGC; support was removed for both options in 14.0");

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              lkorinth Leo Korinth
              Reporter:
              lkorinth Leo Korinth
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: