Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8234237

Update to LLVM9

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: repo-panama
    • Fix Version/s: repo-panama
    • Component/s: tools
    • Labels:

      Description

      Due to a behavior breaking change in one of the libclang APIs, jextract does not run correctly on LLVM8. The problem was fixed with an upstream patch when this was noticed, but until that patch made it into a release, it was decided to require LLVM7 when building the foreign branch.

      Now that LLVM9 is released, which includes the fix, we should look into upgrading our dependency to LLVM9.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jvernee Jorn Vernee
              Reporter:
              jvernee Jorn Vernee
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: