Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8235757

Rename SupportedGC to IncludedGC

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 14
    • Fix Version/s: 14
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
      gc
    • Resolved In Build:
      b27

      Backports

        Description

        GCConfig has a concept of a "supported GC". It means the GCs built into the binary. I'd like to add a check to see if a built GC is supported on the current platform, and then there will be a mixup between the two concepts.

        I'd like to propose that we rename it to "included GC", to use the name we use elsewhere:
        #if INCLUDE_ZGC
          zgc code
        #endif

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                stefank Stefan Karlsson
                Reporter:
                stefank Stefan Karlsson
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: