Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8238988

Rename thread "in stack" methods and add is_in_stack_range

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 15
    • Fix Version/s: 15
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b12

      Description

      Following on from JDK-8234372:

      I think some renaming is needed here:

      Thread::is_in_stack -> Thread::is_in_live_stack
      Thread::on_local_stack -> Thread::is_in_full_stack // I wanted to use "mapped" to imply full stack segment but "mapped" has a special meaning at the OS page level

      We should also add is_in_stack_range that takes a limit and checks that stack_base() > addr >= limit && limit <= stack_end(). This will avoid direct uses of stack_base() in many cases and avoid problems with checking >= versus > etc. Whether the limit is inclusive or exclusive may also have to be specified.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dholmes David Holmes
              Reporter:
              dholmes David Holmes
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: