Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8240315

Shenandoah: Rename ShLBN::get_barrier_strength()

    XMLWordPrintable

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b14
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        ShenandoahLoadReferenceBarrier::get_barrier_strength() is named strangely. This stems from the original attempt to emit different-strength barriers for LRBs that only feed into load-likes (i.e. roughly like previous read barriers) and LRBs that also feed into store-likes (i.e. roughly like previous write-barriers). However, we never followed through with that, and probably never will because the small gains - if any - don't justify the large complexity (e.g. memory/ordering dependencies between weak and strong LRBs).

        The actual implementation only has two strengths: strong and none. Strong means, it has a significant use, and none means no use. Let's rename it to is_lrb_useful().

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                rkennke Roman Kennke
                Reporter:
                rkennke Roman Kennke
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: