Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8242185

Lanai: JDK built on macOS 10.15 fails to run on macOS 10.13

    XMLWordPrintable

    Details

    • Subcomponent:
      2d
    • CPU:
      x86_64
    • OS:
      os_x

      Description

      If a JDK bundle is built on Catalina and run that build on macOS 10.13, it fails with an error message:

      metalEnabled=1
           Metal: Supported, feature set macOS GPUFamily1 v3

      Metal support is present
      2020-03-25 16:59:30.210 java[17400:229311] Failed to create pipeline state, error Error Domain=CompilerError Code=1 "Function frag_col is using language version 2.1 which is incompatible with this OS." UserInfo={NSLocalizedDescription=Function frag_col is using language version 2.1 which is incompatible with this OS.}


      This bug is to investigate -
      1. What should be the expected outcome?
      2. How to handle this gracefully?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kcr Kevin Rushforth
              Reporter:
              aghaisas Ajit Ghaisas
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: