Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8243573

Shenandoah: rename GCParPhases and related code

    XMLWordPrintable

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b22

      Backports

        Description

        ShenandoahPhaseTimings::GCParPhases is awkward: it is plural and it carries unnecessary "GC" prefix. Should be just ShenandoahPhaseTimings::ParPhase. This also matches the local variables "par_phase" to be used to store it, in contrast with just "phase" for ShenandoahPhaseTimings::Phase.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                shade Aleksey Shipilev
                Reporter:
                shade Aleksey Shipilev
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: