Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8243975

Improve G1 naming of identifiers after JDK-8208390

    Details

    • Type: Enhancement
    • Status: Open
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: 15
    • Fix Version/s: tbd
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
      gc

      Description

      JDK-8208390 moves the internal time base from doubles with varying resolution to Ticks/Tickspan.

      This obsoletes a lot of _sec/_ms/* suffixes in method and member names as the type determines its resolution; also we may want to be a bit more specific about whether the (expected) contents are time durations or points in time as just "time" is ambiguous.

      Also, over time a lot of different naming at least for G1GCPhaseTime members accumulated, with various pre- and suffixes which are unnecessary.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tschatzl Thomas Schatzl
                Reporter:
                tschatzl Thomas Schatzl
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: