Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8244648

SunMSCAPI is dependent on ncrypt.dll since 8u251

    Details

      Description

      FULL PRODUCT VERSION :
      8 Update 251

      FULL OS VERSION :
      Windows Embedded POSReady 2009 x86

      A DESCRIPTION OF THE PROBLEM :
      As we rolled out the new update to our Windows Embedded POSReady 2009 tills we noticed that sunmscapi.dll was changed and is now calling ncrypt.dll which represents a problem as those APIs don't exist in our Embedded version of Windows. After we rolled out the update, we replaced sunmscapi.dll from the earlier release. This way, we managed to get Java 8 Update 251 work. This issue breaks Embedded products compatibility.

      STEPS TO REPRODUCE THE PROBLEM :
      Try to run Java 8 Update 251 on a Windows Embedded POSReady 2009 x86 machine.

      JAVA CONSOLE INFORMATION :
      You can easily see the missing APIs from Dependency Walker.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                coffeys Sean Coffey
                Reporter:
                pardesha Pardeep Sharma
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: