Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8244756

Build broken with some awk version after JDK-8244248

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: 15
    • Fix Version/s: 15
    • Component/s: infrastructure
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b23

      Description

      JDK-8244248 breaks build with old awk version (on AIX):
      configure: Found potential Boot JDK using configure arguments
      awk: 0602-521 There is a regular expression error.
      invalid range expression
       The source line number is 1.
       The error context is
      /version >>> \"[0-9\._\-a-zA-Z]+\"/ <<< {print $ 0; exit;}

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mdoerr Martin Doerr
                Reporter:
                mdoerr Martin Doerr
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: