Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8245086

G1: Rename measured pause time ratios

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b25

      Description

      G1 currently uses two values to drive heap resizing (expansion):

      - recent_avg_pause_time_ratio: contains the (calculated) pause time ratio over the last X mutator/gc phases
      - last_pause_time_ratio: contains the (calculated) pause time ratio over the last(*) mutator/gc phase

      (*) this is not entirely true, see JDK-8243672.

      I suggest to rename them to long/short_term_pause_time_ratio to be a bit more flexible about the contents.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tschatzl Thomas Schatzl
                Reporter:
                tschatzl Thomas Schatzl
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: