Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8245926

JFR: Remove chunkSz and rename blockSz from classloader statistics

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P4
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
      jfr

      Description

      This is part of an effort to reduce exposure of Metaspace implementation details somewhat in preparation for JDK-8221173

      In JFR, the classloader statistics event contains the following fields:

      chunkSize
      blockSize
      hiddenChunkSize
      hiddenBlockSize

      blockSize is the interesting one, the number of bytes of Metaspace used by this class loader for storing metadata. I propose to rename this to "totalMetaspaceUsed" resp. "hiddenClassesMetaspaceUsed".

      chunkSize is the total size of chunks given to a class loader. Delta between blockSize and chunkSize constitutes waste if the loader stops loading; however, as far as waste goes this is not very informative since it only is a usually small part of waste in the current metaspace allocator. 
      Moreover, with JDK-8221173 chunks may be partially uncommitted, so that the delta between chunkSize and blockSize may or may not contribute to RSS. So the chunkSize stat becomes more meaningless.

      I'd argue that this stat is quite useless to the average JFR user; and to the VM developer interested in fixing up Metaspace there are better tools (e.g. jcmd VM.metaspace). Therefore I would like to simply remove this stat.

        Attachments

          Activity

            People

            Assignee:
            stuefe Thomas Stuefe
            Reporter:
            stuefe Thomas Stuefe
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: