Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8252530

Fix inconsistencies in hotspot whitebox

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P5
    • Resolution: Fixed
    • Affects Version/s: 17
    • Fix Version/s: 17
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b23
    • CPU:
      generic
    • OS:
      generic

      Description

      1. WB_IsJVMTIIncluded function uses runtime check. Most likely compiler elides the check, but for consistency it would be better to implements the function the same way as others:

      WB_ENTRY(jboolean, WB_IsJVMTIIncluded(JNIEnv* env, jobject wb))
        #if INCLUDE_JVMTI
           return JNI_TRUE;
        #else
           return JNI_FALSE;
        #endif
      WB_END

      2. function names are inconsistent:

      isCDSIncludedInVmBuild / WB_IsCDSIncludedInVmBuild
      isJFRIncludedInVmBuild / WB_IsJFRIncludedInVmBuild
      isC2OrJVMCIIncludedInVmBuild / WB_isC2OrJVMCIIncludedInVmBuild
      isJVMTIIncluded / WB_IsJVMTIIncluded

      As per David suggestion the functions don't need to have "InVmBuild" in the name as it's redundant/unnecessary

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dholmes David Holmes
              Reporter:
              amenkov Alex Menkov
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: