Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8252661

Change SafepointMechanism terminology to talk less about "blocking"

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 16
    • Fix Version/s: 16
    • Component/s: hotspot
    • Subcomponent:
    • Resolved In Build:
      b15

      Description

      The SafepointMechanism class has been used to perform safepoint operations. Now we also perform handshake operations, and soon also concurrent stack processing. Therefore, names such as SafepointMechanism::should_block no longer sound right, when the real questino is whether it should process an operation (be that a safepoint, handshake or whatever else).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              eosterlund Erik Ă–sterlund
              Reporter:
              eosterlund Erik Ă–sterlund
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: