Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8252999

Cleanup: Replace .equals("") with .isEmpty() throughout the codebase

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: New
    • Priority: P4
    • Resolution: Unresolved
    • Affects Version/s: 16
    • Fix Version/s: None
    • Component/s: core-libs
    • CPU:
      generic
    • OS:
      generic

      Description

      A DESCRIPTION OF THE PROBLEM :
      String.isEmpty() is faster, easier to read, and generates less bytecode. It makes sense to replace all occurrences within JDK codebase with the isEmpty() method.

      While the change will affect a lot of components (~150 occurrences in the latest codebase). Change is very easy to review.


        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              webbuggrp Webbug Group
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated: