Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8255723

Gtk glass backend should run with Gtk+ 3.8 (minimum)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: openjfx14
    • Fix Version/s: openjfx16
    • Component/s: javafx
    • Labels:

      Description

      on gladd_dnd.cpp:

      #if GTK_CHECK_VERSION(3, 10, 0)
          context = gtk_drag_begin_with_coordinates(drag_widget, tlist, actions, 1, NULL, x, y);
      #else
          context = gtk_drag_begin(drag_widget, tlist, actions, 1, NULL);
      #endif


      This will break if run on previous Gtk than 3.10.0.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              tsayao Thiago Sayao
              Reporter:
              tsayao Thiago Sayao
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: