Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8256277

Github Action build on macOS should define OS and Xcode versions

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 16
    • Fix Version/s: 16
    • Component/s: infrastructure
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b25
    • OS:
      os_x

      Description

      For a verification job like our use of Github Actions is used as, we need to better control the build environment to avoid surprises. For Macos, Github current provides two different images, macos-10.15 and macos-latest. The latest is a moving target and because of that, I don't think it should be used. The image also comes with a whole range of different Xcode versions. Here we need to pick one we know works and stick with it. At Oracle we are currently using 11.3.1 so I would suggest sticking with the same version to avoid discrepancies.

      https://github.com/actions/virtual-environments/blob/main/images/macos/macos-10.15-Readme.md

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              rwestberg Robin Westberg (Inactive)
              Reporter:
              erikj Erik Joelsson
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: