Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8256484

ZGC: Rename ZRelocationSetSelector::register_garbage_page()

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 16
    • Fix Version/s: 16
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
      gc
    • Resolved In Build:
      b25

      Description

      This came up in a review of a separate change. ZRelocationSetSelector::register_garbage_page() is slightly misleading, since live pages can also contain garbage. A better name is ZRelocationSetSelector::register_empty_page().

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              pliden Per Liden
              Reporter:
              pliden Per Liden
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: