Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8257020

[JVMCI] enable a JVMCICompiler to specify which GCs it supports

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 16
    • Fix Version/s: 16
    • Component/s: hotspot
    • Subcomponent:
    • Resolved In Build:
      b28

      Description

      A number of jtreg tests require a specific GC. These tests should be ignored when EnableJVMCI is true and the JVMCI compiler does not support the required GC.

      This requires adding JVMCICompiler.isGCSupported and making use of it in WhiteBox.isGCSupported.

      Without this enhancement, tests requiring GCs not yet supported by GraalVM fail as follows:

      Error occurred during initialization of VM
      JVMCI Compiler does not support selected GC: epsilon gc


      This RFE improves upon JDK-8231503. The problem with that change is that the VM execution used to ascertain whether JVMCI is supported only looks at the *selected* GC as opposed to the *supported* GCs.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dnsimon Douglas Simon
              Reporter:
              dnsimon Douglas Simon
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: