Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8257083

Security infra test failures caused by JDK-8202343

    XMLWordPrintable

    Details

      Backports

        Description

        There are several infra test failures that were caused by the fix for JDK-8202343.

        The problem is that test/jdk/javax/net/ssl/TLSCommon/interop/JdkProcClient.java is designed to be run with different versions of the JDK such as JDK 8 but now calls SecurityUtils.removeFromDisabledTlsAlgs() which calls APIs such as List.of() that are not available in JDK 8.

        The fix is to create a private method which does the same thing as SecurityUtils.removeFromDisabledTlsAlgs() but doesn't depend on newer APIs.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mullan Sean Mullan
                Reporter:
                mullan Sean Mullan
                Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: