Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8259849

Shenandoah: Rename store-val to IU-barrier

    XMLWordPrintable

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b06
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        We named the IU barriers StoreValEnqueueBarrier and various similar variations of this. Instead of naming it after how it's implemented, we should name it after its purpose: support IU-marking. It also looks confusing to have enqueue_barrier() and similar stuff, where no barrier is actually enqueued.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                rkennke Roman Kennke
                Reporter:
                rkennke Roman Kennke
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: