Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8260518

Change default -mmacosx-version-min to 10.12

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b08
    • OS:
      os_x

      Backports

        Description

        To guarantee backwards compatible binaries on Macos, we use the option -mmacosx-version-min. This is currently set to 10.9, which is a really ancient version. I propose we bump this to 10.12, which is still a rather conservative old version (support ended in 2019).

        The driving issue for bumping this now is the aarch64 port, where building for aarch64 requires the version min to be set to 11.0. Having a large gap between the target versions becomes problematic as we hit a lot of deprecation warnings in shared code. To be able to fix these deprecation warnings, we need a smaller version gap.

        Just bumping us to 10.12 triggers warnings in libsplashscreen, so I will temporarily add "deprecated-declarations" to the list of disabled warnings there until they can be fixed in JDK-8260402.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                erikj Erik Joelsson
                Reporter:
                erikj Erik Joelsson
                Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: