Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8261766

[8u] hotspot needs to recognise cl.exe 19.16 to build with VS2017

    XMLWordPrintable

    Details

    • Resolved In Build:
      b04

      Description

      Similar to https://bugs.openjdk.java.net/browse/JDK-8209359

      Need to update the build scripts for 8u to recognise values for MS_VER "1914", "1915" and "1916".

      This fixes building 8u with VS 2017 version 15.9 (cl.exe 19.16).

      Attempt to build current 8u repo with VS 2017 15.9 fails with:

      > adlc.exe.manifest : general error c1010070: Failed to load and parse the manifest. The system cannot find the file specified.

        Attachments

          Activity

            People

            Assignee:
            dcherepanov Dmitry Cherepanov
            Reporter:
            dcherepanov Dmitry Cherepanov
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: