Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8264219

tools/scripts/build.ps1 is out of date and no longer works

    XMLWordPrintable

    Details

      Description

      A comment was added to PR #212 [1], which was the review for JDK-8242508 to update the JavaFX build to use Visual Studio 2019 (from 2017), to the effect that the tools/scripts/build.ps1 script no longer works.

      That script still attempts to install and use the VS 2017 tool chain, which may not work properly. We do not use or reference that script at all. It used to be used in our old sandbox repo when running AppVeyor builds on GItHub, and also some developers may be using it (at least the one who added the comment to the PR).

      The comment lists three problems:

      1. Build script located in tools/scripts needs to be updated [to use VS 2019]

      2. Build fails with `FAIL: WINSDK_DIR not defined`

      3. It's not possible to install Windows SDK 7.1 on Windows 10

      The dependency on Windows SDK 7.1 has been eliminated, so that should just be removed from the script. Given the fix for JDK-8255713 it probably wouldn't be too hard for someone to update the script to use VS 2019 and get this working again.

      [1] https://github.com/openjdk/jfx/pull/212#issuecomment-790105330

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kcr Kevin Rushforth
              Reporter:
              kcr Kevin Rushforth
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: