Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8264848

[macos] libjvm.dylib linker warning due to macOS version mismatch

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b18
    • CPU:
      x86
    • OS:
      os_x

      Backports

        Description

        Object files which flow into libjvm.dylib are created with -mmacosx-version-min=10.12.0. The same option is passed to the linker. Unfortunately, there is one assembler file (bsd_x86_64.s) which does not receive the option at assembly time. That leads to the linker warning

        ld: warning: object file (<buildRoot>/hotspot/variant-server/libjvm/objs/bsd_x86_64.o) was built for newer macOS version (10.15) than being linked (10.12)

        when linking on a system with a MacOS version different from 10.12. n

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                lucy Lucy Schmidt
                Reporter:
                lucy Lucy Schmidt
                Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: